Android app updated - lost all entries in database

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

3 posts • Page 1 of 1
Yesterday I had a pretty full databaase, today I run it, the UI has changed, although I didn't update anything. Database has been cleared to 0 entries.
What happened and is the data still available some place? Did not have a chance to upload.
What UI changes are you seeing?

There are few circumstances under which something like this might happen.

1. This could be a result the Android storage change - Google is forcing apps into "internal" storage - which would "orphan" the old database. That file won't be gone, just no longer in the correct location. Perhaps your handset was recently updated to a new version of Android? If you're up for it, you can either move the database into place, or just copy if from the device.

2. This could be a result of a permission revocation. Android started turning off permissions for "unused" apps, so if you're an infrequent user, it may have revoked the "external storage" permission (you can turn it back on in settings -> app -> WiGLE)

Depending on your device, OS version, app version, and previous settings, there are a lot of possibilities for "where" the files are located. Send us email with details to WiGLE-admin[at]wigle.net if you don't want to share that information.
The application version is listed at the bottom of the "Settings" activity.
It was an ID10T error. I assumed the app was upgraded automatically since the screen looked very different. Turns out something was in a messed up state. Rebooting the phone brought everything back to looking normal and the formerly blank database display was back to normal.

Doh

3 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: ag-spike and 1 guest