No map - "update google play services"

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

3 posts • Page 1 of 1
I have Android 2.3.6 Samsung Galaxy Ace smartphone with Wigle 2.7 installed. When launched it says it requires Google Play Services installed. That *** takes all available internal memory space (no other custom apps installed) abut 40 Mb for app and 90mb for data then the device works very slowly. This problem solved by moving Google Play Services to the memory card, now 100+ free internal memory. Background updates are enabled.

Finally, 2.7 maps tab shows "updating google play services..." and no map at all. I updated the app to 2.21 (seems last version that supports Android 2.3) and when started it shows a message box says it's necessary to update Google play services to launch Wigle Wifi (sorry, translated into EN from my native language) with Update button. I press it and nothing happens, only blank white screen until I exit to desktop. Now Google Play Services has 41.7 Mb apk (SD card) + 4.23 Mb Dex (internal) + 6.27 Mb Lib (SD card) + 57.27 Mb data (internal memory).

Could somebody guess what happens on my smartphone or if there any Wigle Wifi version that use alternative maps (with no google services)?
Hi jackri,

Sorry to hear you're having trouble.
We don't currently support any other party's mapping services, but we do have a FOSS-only build that excludes maps and should prevent the request for play services: has a link.

Are you using a stock OS or custom?


Hi. Stock OS.
There are some hacks how to disable google play services, but I need maps :D
There is a pre-installed google maps application that worked without play services, so that was a reason of my question about if there any (maybe old) build that does not require it.

People say that looks like play services problem, I will play with this phone for some more time to check it.

I found the sources at github. Specially to solve this s**t I installed Android Studio and forked build from Aug 22 2017.
Just GooglePlayServicesUtil.isGooglePlayServicesAvailable returns code 2 = SERVICE_VERSION_UPDATE_REQUIRED. It looks like not your code but some Google bug, seems I must write to Google technical support.

P.S. I found there are at least 3 alternatives: osmdroid, yandex maps and static maps from Google.

3 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest