User Statistics not displaying correctly on Android Pie?

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

5 posts • Page 1 of 1
I just got a new phone (Pixel 2 XL running "Pie") and notice that the statistics page in the wigle app is borked. Well, not completely. Toggling through the statistics pages.....
1) " Rankings" is blank with a popup error message (unable to connect to wigle, please check your connection...) [but I can browse to on chrome, so methinks it is connected to internets]
2) " Statistics" shows data
3) "User Statistics" shows "?" or "Unknown" for every entry where one would expect to see a number, and it shows the same error message, as if it can't resolve

I've been using wigle on the pixel for a few days now. I am logged in with my wigle account. Anonymous upload is not checked. I'm using my old nexus 5 for wigle also, but the stats show fine on that. When I setup the Pixel 2, I used the handy usb-c to usb-a connector to copy everything over. The app seems to function okay otherwise, besides performing nowhere near as well as my old Nexus 5 at finding all the WiFi.

I have no knowledge of the situation prior to the "Pie" update, as it was offered during initial setup of the phone and I just clicked through to install.
that's really weird - would you mind de-authorizing and re-authorizing with WiGLE, to see if that problem persists?

Sorry for the trouble,

Thank you, arkasha! That did it. I guess Google restored the token from my Nexus 5 to the Pixel, and it wasn't getting past the gatekeeper.I had noticed the "authorize" button before, but nothing happened when I tapped it. After removing my username and token from settings, on the next launch of the app I went back to settings and there was the "activate" link. Perhaps of note is that, while it was in the non-working state, my username and the auth token were present, but the "deauthorize" was not present.

Perhaps one day the Wigle client might recognize this sort of authentication failure and prompt the user to the remedy.

Thanks again, arkasha. +1,000,000 cred to you.
this is a great note - we'll make sure we don't restore incompatible tokens from older devices. Google just flat out retired some cipher suites from version to version (and broke one completely) and it's been a *misery* for us to match.

Thanks for the help in diagnosing thing, sorry for the problems.

I just "upgraded" from a Nexus 5X with 8.1.0 to a Pixel XL with Android 9 and saw the same problem. WiGLE appeared to install and work but scanned data was not uploaded and vanished whenever WiGLE was turned off. The dashboard would show a nets scanned count on the drive into work but when I turned the app off and back on again, everything was lost. The login did not work until I deleted the user name and password (which were showing up correctly) and then allowed the Google password service to re-enter them - Authorize then worked.

After re-entering the password and hitting authorize everything seems to be OK, data scanned but not uploaded is preserved between restarts. I was about to check the Pixel and go back to the Nexus - LOL.

5 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: Theusu5k and 1 guest