Waiting for GPS sync

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

4 posts • Page 1 of 1

Postby cmhall9 » Sun Jan 06, 2019 4:11 am

On the NETWORK LIST page, Lat: displays "Waiting for GPS sync".
After an hour of playing with the app and the phones setting WiGLE WiFi never syncs with the gps.
On the MAP page it defaults to San Francisco, but will move to my location only if I tap the "center on me" icon.
Also on the MAP page there are no networks shown.

My phone is a LGG6.
GPS is on, android default maps app shows my location.
App-level permissions for WiGLE WiFi is on.

Installed your app a couple of hours ago.
First time user.
App referred by Null Byte.

Postby arkasha » Tue Jan 08, 2019 7:01 am

sorry to hear that, and thanks for your interest and the report.

I've seen some weird GPS behavior in recent android releases (Oreo and Pie, specifically) that line up with this.
A couple of checks to get to the bottom of this:

1. bring up the "dashboard" tab - what value is next to the "Loc:" label? (non-"GPS" fixes have device-specific quirks, we can start examining those if it says "network" or "passive" in particular)

2. What android version are you on? Specifically, Android Pie has throttled network scanning to 4 scans/2 minutes which might be part of the problem with networks showing up on the map. The API documentation says that this is preparation for removing scan permissions entirely, which would be a shame for the technical community. There were also some serious new releases around API 24, and I've definitely noticed a decrease in speed and quality on several devices that were working quite well before the upgrade.

3. (I hate to say this, but it's worked for me twice when I've seen behavior like this on Oreo): Have you tried turning it off and on again? I've seen GPS jams that appear to be associated with other GPS-using apps crashing/becoming unstable (looking at you, Lyft), and stopping/starting WiGLE or relaunching those apps can't seem to wake the GPS driver or maybe even chipset back up. Powering the device off and back on has done the trick both times, but ... what a pain.

anyway, sorry for the trouble, hope this helps,


Postby cmhall9 » Mon Jan 21, 2019 6:28 pm


I uninstalled the app shortly after posting my question. A couple of days ago my phone had a software update, so I reinstalled the WiGLE app.
The GPS now works. The map syncs right on my location and is now showing a bubble with a number of local access points.
My software version is now, VS98820f.

Postby arkasha » Mon Jan 21, 2019 6:59 pm

awesome - glad it was a transient failure, and not some horrible oversight on our part.
I had a very similar experience.

Cheers, and keep on stumblin'!


4 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest