Waiting for GPS sync (tested on 2 different devices)

Issues with the Android network detection software. Please include Software version, Android version, and device when reporting

4 posts • Page 1 of 1
I installed the Android app on two devices and on both it is stuck on "Waiting for GPS sync". I checked all the settings and permissions and it should work. The map recognizes my location, but the app doesn't. On my dashboard there is a red cross after "Loc".

I tried reinstalling the app and I restarted the phones several times.

Any idea what's causing this?

Thanks in advance. The app looks great and I'd love to get it working.
sorry to hear that; we've had a few isolated reports like this, but never anything reproducible on a more than individual scale.

Some things that would help:
1. Android version(s)
2. location settings - how did you verify app access
3. Testing location/local
4. carrier
5. devices
6. your location

Obviously if you're not comfortable sharing those on a public forum, we're happy to switch to email (WiGLE-admin[at]wigle.net) or PM.
If you happen to be an Android developer the best possible case would be watching the process logs as you launch the app - if there's an error, it would manifest there. If it's just a really bad GPS sync, there won't be much useful. So far, in one case, we discovered that post schism, Huawei has started *changing* Android in ways that don't comply with the spec. In others, devices were operating on purely network location but the app wasn't allowed to receive network location data.
Thank you for your quick response.

Apparently the GPS signal is very weak inside my house, because outside the app was working well.

I have had an old Galaxy S6 that I was using purely for Wigle as I needed the sqlite file. It has since died (kernel is not seandroid enforcing and now could not do normal boot - invalid kernel length) and so I installed wigle 2.60 on an older J5. I get the Waiting for GPS sync etc and get 0 0 0 in the wifi / bt / cell counters. As before the map quite happily shows my pos. I did bring the phone indoors and it showed GPS Lost and the counters updated but only once. I have rebooted, started with seeing GPS, without seeing GPS etc and cannot get anything except 0 0 0. I have tried versions down to 2.29 and the all give Waiting for GPS sync...

I have a logcat with a grep of 'wigle' but that won't mean much to me!

Was this ever solved?

4 posts • Page 1 of 1

Return to “WiGLE WiFi Wardriving Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest