HTTP 405 Method Not Allowed when trying to search through basic search

Report issues with the site here. Please include browser and page information in your reports.

6 posts • Page 1 of 1
I'm trying to search for a SSID from the basic search page ( but all I get is "HTTP 405 Method Not Allowed" exception at the URL
that's super weird. "works for me" is the most annoying answer in situations like this, but it is working for me.

A few questions:
1. does it fail in different browsers?
2. did your login expire in the background? (we could be more proactive about this)
3. are you using any unusual browser plugins?
4. does it work from other networks? (i.e. try your phone hotspot) - WiGLE does make some folks block-lists because we're "h4XX0rs"
1) Appears to fail only in Firefox on both Windows and Linux. It works fine on Chrome and IE.
2) Nope, login is active and advanced search works
3) Tried it with Firefox without any extensions same results.
4) Doesn't appear to be source ip related, IE and Chrome work on the same network.
Last edited by strasharo on Sat Sep 22, 2018 8:42 am, edited 1 time in total.
That a good find - also it's super obnoxious. If you look at the network traffic console, it's sending the search request as a POST instead of a GET, even though the jquery ajax request is explicitly configured to use GET.

We'll try and figure out whether we've got some kind of subtle misconfiguration, or whether Firefox isn't respecting the parameter for some reason. Thanks for the heads-up and watch this space.
hah, tracked it down - totally my fault; i tried to DRY-up the code a little too hard. Clear your cache and try again?

Thanks for the find; we appreciate your help!

Yep, works fine now, thanks a lot :D

6 posts • Page 1 of 1

Return to “WiGLE Site Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest