Bug Reporting?

Talk about whatever

11 posts • Page 1 of 1

Postby fritzalo » Wed Aug 02, 2017 4:07 pm

Hi All,

Where would I report a bug? I just switched to a Nexus 6p on Build Number OPP4.170623.014 and tried to authenticate to the wigle app and it continuously tells me that my creds aren't correct. I've logged into the website using the same creds, and tried other android devices with the same credentials and its working fine. Something to do with the app and the new android beta don't play well together.


Postby arkasha » Thu Aug 03, 2017 2:48 am

this is a great spot. You can also reach us via email at WiGLE-admin@wigle.net

Have you deauthorized and re-authorized?

Postby fritzalo » Thu Aug 03, 2017 8:47 pm

Thanks for the response!

I have clicked the Deauthorize button in the app.

When I try to login(authorize) again, it tails me the login is incorrect. If I close the app and reopen it, it shows the account being there with the DeAuthorize button being clickable. If I try any actions though, like uploading or going to User Statistics I get a pop up that says Login failed, check password?

This persists even through reboots of the phone, and closing the app.

When I try the authorize button it says login failed, check password, but upon reopening the app will show being logged in and continues with the behavior of not letting me do anything and telling me my creds are invalid.

Postby arkasha » Thu Aug 03, 2017 10:45 pm

We've seen issues like this in a couple of instances where OS upgrades have rendered the application encryption keys inaccessible. Reinstallation may fix the issue, but we'd be really interested in the application logs if you can send them to us!

Do i understand correctly that this is a new install on a new device?

Is there any chance you moved files over from another device?

Thanks, sorry for the difficulties.

Postby fritzalo » Fri Aug 04, 2017 1:19 am

This is a brand new device with a brand new copy of the WigleWifi app installed. I'll try reinstalling it now.

*Edit* Reinstalling it did not help.* :(

Whats the best way to get logs off for you?

Postby arkasha » Sat Aug 05, 2017 7:44 pm

I've lined up a 6p to test with - will post the results here Monday!



Postby arkasha » Sun Aug 06, 2017 9:03 pm

We've got this down to a minimal reproducible case; getting ready to report to Google.
Info to follow. Until this gets resolved, I guess we aren't compatible with Android O. :(

Postby fritzalo » Sun Aug 06, 2017 11:16 pm

Thanks for going through this with me. I figured it was on the google side of the house, but they have been hard for me to get to. :)

Postby arkasha » Mon Aug 07, 2017 5:32 pm

Moving conversation to our new Bugs forum - viewtopic.php?f=13&t=2465 for this issue.

Postby fritzalo » Tue Aug 08, 2017 2:09 am

Is the general population supposed to be able to see that section? I can't post or view there.

Postby arkasha » Wed Aug 09, 2017 5:50 pm

I'd initially made a mistake in the config- should be fixed now!

11 posts • Page 1 of 1

Return to “General Grabbag”

Who is online

Users browsing this forum: No registered users and 8 guests